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Task 1 - Inkscape
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Our client, Fab Gadget Ltd., has asked 
us to create a logo for them. Many 
different pre-production meetings 
have been held and the final design 
has been decided upon. It is your job 
to create the logo as a vector graphic 
so that it can be used across all of 
their different promotional materials. 
The final design is pictured on this 
slide:



Task 1 - Creating a website
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Assets that are needed to complete this task can be obtained here: 
oaknat.uk/comp-digital-graphics

https://www.google.com/url?q=http://oaknat.uk/comp-digital-graphics&sa=D&source=editors&ust=1620230746253000&usg=AOvVaw3cESgWyQ7vF2hzgSDuKUCI
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Step 1

Open InkScape on your 
computer

Step 2

Select the Circle tool from 
the left-hand side

● This is the icon for the 
circle tool:

Step 3

Draw a circle by clicking 
and dragging with your 
mouse.

● To keep your circle in 
proportion, hold 
down CTRL and Shift 
together while you 
draw it.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 4

Move the circle into the centre of the 
page

● Use the Select tool and click and 
drag the circle to position it where 
you want

Step 5

Adjust the Fill and outline (called Stroke 
in Inkscape) of the circle.

● With the circle selected, choose your 
Fill colour from the colour bars 
across the bottom of the screen. In 
the example, we have used 7.5% grey

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 5 - Continued

Now, while holding the Shift key, select 
the colour for your Stroke. In the example, 
we have used 70% grey. You should now 
have a circle that looks like this:

Step 6

Add the text

● Click on the Create text tool from 
the left-hand side  and click on some 
white space on the page and type 
FAB GADGET LTD..

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 7

Change the font

● Press Shift + Ctrl + T to open the 
Text and Font tools and select a 
font. Press Apply when you have 
found the one that you want.

Step 8

Wrap the text around the circle.

● Using the Select tool, select the text 
and then hold Shift and select the 
circle too. Now, from the main menu, 
select Text > Put on Path.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 9

Flip the text inside the circle.

● With both the circle and text still 
selected, press the Flip selected 
objects horizontally button or press 
H on the keyboard.

Step 10

Increase the letter spacing.

● Click on the Create text tool from 
the left-hand side again, and then 
from the top menus, increase the 
Spacing between letters value until 
it looks right. 

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 11

Position the text at the bottom of the 
circle.

● Select just the circle with the Select 
tool and click on it a second time so 
the Rotate tools appear Now, rotate 
the circle to position the text at the 
bottom of the circle.

Step 12

Turn the text into a vector path.

● Select just the text and go to Path > 
Object to Path from the main menu, 
or press Shift + Ctrl + C. You have 
now disassociated the text from the 
circle.

Create the logo by completing the steps below

Task 1 - Inkscape



10

Step 13

Enlarge the circle.

● Select just the circle and, while 
holding Shift + Ctrl, stretch the circle 
from the top left-hand corner to 
make it slightly larger so that the 
text sits inside the circle.

Step 14

Change the text colour.

● Select the text and change the 
colour. We have used a goldish 
colour in the example.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 15

Add a drop shadow to the text.

● With the text still selected, right-click 
on it and select Duplicate, then 
change the colour to dark grey. Now, 
lower the new text down a layer by 
pressing Page down, and finally, 
offset it by pressing the down cursor 
once.

Step 16

Create the yellow sun.

● Draw a circle in the middle of your 
grey circle while holding Shift + Ctrl. 
Don’t worry if it is not in exactly the 
right place; you will align it next.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 17

Align the yellow sun.

● Click on the Select tool, and with the new circle 
still selected, hold down Shift and select the 
outer circle. Now, press Ctrl + Shift+ A to open 
the Alignment tools.

● Change the Relative to: to Last selected and 
then click both the Centre on vertical axis and 
Centre on horizontal axis buttons.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 18

Remove the stroke from the yellow sun

● Select just the inner circle by clicking in the 
white space and then selecting the inner circle 
again. Now, hold down the Shift key and select 
the white square with a red cross through it at 
the start of the colour selector.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 19

Change the Fill colour of the yellow sun.

● With the inner circle still selected, let 
go of Shift and select the colour from 
the bottom menu; you may need to 
scroll to the right to see all the colours.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 20

Change the Fill to a Gradient.

● Select the Gradient tool from the left-hand side 
and from the tool presets at the top of the 
screen, select to create a radial gradient.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 20 - Continued

Now, double-click on the circle to create the radial 
gradient. Adjust the two handles to get the size and 
effect of gradient that you want.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 21

Create the lightning bolt. Start with a square.

● Select the Create rectangles and squares tool from the left-hand side  and draw in 
a square in the white space around your logo, holding down Shift + Ctrl while you 
draw the shape to make it a perfect square.

Create the logo by completing the steps below

Task 1 - Inkscape



18

Step 22

Rotate the square.

● Now, use the Select tool and click on the square again so that the Rotate handles 
appear: Then, while holding Ctrl, move the top right-hand corner down three times 
so that your square is rotated through 45 degrees.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 23

Convert the square into a vector path.

● Select the square and then choose Path > Object to path from the main menu or 
press Shift + Ctrl + C.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 24

Turn the square into a triangle.

● Select the Edit paths by nodes tool from the left-hand side 
and select your square. Click to select the handle at the 
bottom of your square, then press Delete. You will then 
have two handles and your shape should look a little like 
the image to the right. Move the two handles up to the left 
and right respective handles so that your shape becomes a 
triangle.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 25

Reduce the height of the triangle.

● Select the triangle using the Select tool again and decrease the height of the 
triangle until your shape looks a little like this:

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 26

Rotate the triangle.

● Click on the triangle again to bring up the Rotate 
tools, and rotate the shape until it is in this 
position:

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 27

Duplicate the triangle, flip it, and make the lightning bolt.

● Right-click on the triangle and select Duplicate or press Ctrl + D, then press V and H 
to flip the duplicated shape both horizontally and vertically.

● Now, use your cursor keys to position the shapes until they make the shape of a 
lightning bolt.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 28

Join the two triangles together.

● Select both triangles by drawing a box around 
them.  Select Path > Union from the main menu 
to join the shapes together.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 29

Change the colour of the lightning bolt and position it.

● You can now change the colour of the lightning bolt or set a gradient in the same 
way as you did for the inner circle. Once you are happy with the colour, position the 
lightning bolt in the centre by selecting the lightning bolt and then the outer circle, 
and then aligning it horizontally and vertically, as you did in Step 17.

Create the logo by completing the steps below

Task 1 - Inkscape
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Step 29

Save and export your logo.

● Save your logo as an SVG file by selecting File > Save as.
● Export it to a PNG image by selecting File > Export PNG Image….

Create the logo by completing the steps below

Task 1 - Inkscape
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Our client, Fab Gadget Ltd., has asked us to 
create a poster for their latest robotic 
lawnmower. The pre-production meetings 
have been completed and the graphical 
assets and wording have all been decided 
upon already. The have been supplied to 
you within the Zip Folder. When there are 
multiple pictures of the same thing, you are 
free to select the one that you prefer. The 
wording is indicated in the steps on the 
coming slides. You will make use of the 
open source application GIMP to design 
your poster.
.
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Step 1

Open GIMP on your computer.

Step 2

Create an empty A4 document.

● Create a new file by pressing Ctrl + 
N. Select A4 (300 ppi) from the 
template and click on OK.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 3

Add a lawn picture as a background.

● Press Ctrl + o to open a new file and browse to one of the 
pictures of a garden lawn.

● Select all of this image by pressing Ctrl + A and then copy 
it by pressing Ctrl + C.

● Select your original tab as indicated here
● Paste the lawn image as a new layer into the poster by 

selecting Edit > Paste as > New Layer from the main 
menu.

Create the poster by completing the steps below

Task 2 - GIMP



30

Step 4

Resize the layer.

● Select the Unified Transform Tool from the top left-hand 
side.  

● Click on the lawn image. Stretch the image to cover the 
whole background by dragging it by the corner of the 
outer square handle as indicated here:

● Press Enter to perform the transform.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 5

Add a robot lawnmower picture

● Open the image that you want to use and copy and paste it as a new layer in the 
same way as you did in Step 3.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 6

Remove the background of the robot lawnmower.

● Use the Eraser tool  to erase the background from around 
your robot lawnmower so that it looks like it is sitting on 
top of the lawn that you pasted before. 

● If you want to resize this layer, use the Unified Transform 
Tool in the same way as when you resized the background. 

Create the poster by completing the steps below

Task 2 - GIMP
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Step 7

Position the robot lawnmower. 

● Use the Move tool  to position your robot lawnmower where you want it on your 
poster.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 8

Add a relaxing picture to the poster.

● Follow the same steps as above to include one of the relaxing pictures. 
● Remove its background using the Eraser tool. 
● Scale and position the image using the Unified Transform Tool.
● Tip: If you make a mistake, use Ctrl + Z to undo your changes. You can zoom in by 

pressing the + button and zoom out by pressing the - button.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 9

Add a manual lawnmower picture to the poster.

● Repeat these steps again to add one of the pictures of a manual lawnmower to 
your poster.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 10

Add text to the poster.

● Click on the Text tool  and click on your poster. Type the 
following:

● Why work up a sweat when you could put your feet up 
with the new robot mower from Fab Gadget? 

Create the poster by completing the steps below

Task 2 - GIMP
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Step 11

Change the font and size of the text.

● Use the Text tools to change the font and size of the text. 
Use the handles to control the size of the text box. 

Create the poster by completing the steps below

Task 2 - GIMP
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Step 12

Add a drop shadow to the text.

● Make sure you have your text layer selected, and then go to Filters > Light and 
shadow > Drop shadow from the main menu.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 13

Add the Fab Gadget logo.

● Open the PNG file of the logo that you created in the ‘Create vector graphics with 
Inkscape’ activity.

● Now, copy and paste it as you did with the other images. Note: There is no need to 
delete the background of this image, as it was saved with a transparent 
background from Inkscape. 

● Use the tools to scale and position the logo where you want it.

Create the poster by completing the steps below

Task 2 - GIMP
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Step 14

Save and export your file.

● Use File > Save as to save your file as an .xcf file. This is GIMP’s native file format 
and will preserve all of the layers so that you can edit it later if you need to.

● Now, export your poster as a raster graphic file by selecting File > Export from the 
main menu. It will default to saving a .png file with the same name as the file that 
you just saved. Click on Export twice to complete the poster.

Create the poster by completing the steps below

Task 2 - GIMP


